<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta content="width=device-width, initial-scale=1.0, user-scalable=no" name="viewport">
<title>Wharton 2Y Embarrasses Famous Rapper on Stage and Saves 1000s of Lives in a Single Day | Wharton Journal</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://whartonjournal.com/xmlrpc.php" />

<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel="alternate" type="application/rss+xml" title="Wharton Journal &raquo; Feed" href="http://whartonjournal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Wharton Journal &raquo; Comments Feed" href="http://whartonjournal.com/comments/feed/" />

            <script type="text/javascript">//<![CDATA[
            // Google Analytics for WordPress by Yoast v4.3.5 | http://yoast.com/wordpress/google-analytics/
            var _gaq = _gaq || [];
            _gaq.push(['_setAccount', 'UA-26359921-1']);
				            _gaq.push(['_trackPageview']);
            (function () {
                var ga = document.createElement('script');
                ga.type = 'text/javascript';
                ga.async = true;
                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';

                var s = document.getElementsByTagName('script')[0];
                s.parentNode.insertBefore(ga, s);
            })();
            //]]></script>
			<link rel="alternate" type="application/rss+xml" title="Wharton Journal &raquo; Wharton 2Y Embarrasses Famous Rapper on Stage and Saves 1000s of Lives in a Single Day Comments Feed" href="http://whartonjournal.com/2015/04/13/wharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"http:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/whartonjournal.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.3.7"}};
			!function(a,b,c){function d(a){var c=b.createElement("canvas"),d=c.getContext&&c.getContext("2d");return d&&d.fillText?(d.textBaseline="top",d.font="600 32px Arial","flag"===a?(d.fillText(String.fromCharCode(55356,56812,55356,56807),0,0),c.toDataURL().length>3e3):(d.fillText(String.fromCharCode(55357,56835),0,0),0!==d.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='flick-css'  href='http://whartonjournal.com/wp-content/plugins/mailchimp//css/flick/flick.css?ver=4.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimpSF_main_css-css'  href='http://whartonjournal.com/?mcsf_action=main_css&#038;ver=4.3.7' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='mailchimpSF_ie_css-css'  href='http://whartonjournal.com/wp-content/plugins/mailchimp/css/ie.css?ver=4.3.7' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='contact-form-7-css'  href='http://whartonjournal.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=3.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='recent-facebook-posts-css-css'  href='http://whartonjournal.com/wp-content/plugins/recent-facebook-posts/assets/css/default.css?ver=1.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='dw_focus_template-css'  href='http://whartonjournal.com/wp-content/themes/dw-focus/assets/css/dw-focus.min.css?ver=4.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='dw_focus_responsive-css'  href='http://whartonjournal.com/wp-content/themes/dw-focus/assets/css/dw-focus-responsive.min.css?ver=4.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='http://whartonjournal.com/wp-content/themes/dw-focus/style.css?ver=4.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='print-style-css'  href='http://whartonjournal.com/wp-content/themes/dw-focus/assets/css/print.css?ver=4.3.7' type='text/css' media='print' />
<link rel='stylesheet' id='dw-focus-qa-css'  href='http://whartonjournal.com/wp-content/themes/dw-focus/dwqa-templates/style.css?ver=4.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='attachment-css-css'  href='http://whartonjournal.com/wp-content/plugins/document-attachment-widget/css/attachment_widget.css?ver=4.3.7' type='text/css' media='all' />
<script type='text/javascript' src='http://whartonjournal.com/wp-includes/js/jquery/jquery.js?ver=1.11.3'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/plugins/mailchimp/js/scrollTo.js?ver=1.2.10'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.18'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mailchimpSF = {"ajax_url":"http:\/\/whartonjournal.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/plugins/mailchimp/js/mailchimp.js?ver=1.2.10'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/plugins/mailchimp//js/datepicker.js?ver=4.3.7'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/themes/dw-focus/assets/js/jquery.mouse.move.js?ver=4.3.7'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/themes/dw-focus/assets/js/jquery.swipe.js?ver=4.3.7'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/themes/dw-focus/assets/js/jquery.infinitescroll.min.js?ver=4.3.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"http:\/\/whartonjournal.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/themes/dw-focus/assets/js/dw-focus.min.js?ver=4.3.7'></script>
<script type='text/javascript' src='//platform.twitter.com/widgets.js?ver=4.3.7'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://whartonjournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://whartonjournal.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Commuting Guidance for the Class of 2017' href='http://whartonjournal.com/2015/04/13/commuting-guidance-for-the-class-of-2017/' />
<link rel='next' title='We Are Wharton' href='http://whartonjournal.com/2015/04/19/we-are-wharton/' />
<meta name="generator" content="WordPress 4.3.7" />
<link rel='canonical' href='http://whartonjournal.com/2015/04/13/wharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2/' />
<link rel='shortlink' href='http://whartonjournal.com/?p=4542' />
<script type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-26359921-1']);
_gaq.push(['_trackPageview']);
(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
	<script type="text/javascript">
		jQuery(function($) {
			$('.date-pick').datepicker({
				autoFocusNextInput: true,
				constrainInput: false,
				changeMonth: true,
				changeYear: true,
				beforeShow: function(input, inst) { $('#ui-datepicker-div').addClass('show'); },
				dateFormat: 'yy/mm/dd',
			});			
			
			d = new Date();
			$('.birthdate-pick').datepicker({
				autoFocusNextInput: true,
				constrainInput: false,
				changeMonth: true,
				changeYear: false,
				minDate: new Date(d.getFullYear(), 1-1, 1),
				maxDate: new Date(d.getFullYear(), 12-1, 31),
				beforeShow: function(input, inst) { $('#ui-datepicker-div').removeClass('show'); },
				dateFormat: 'mm/dd',
			});
			
				
		});
	</script>
	    
    <style type="text/css">
    #tp_thumbs{ 
        padding-top: 10px; 
        overflow: hidden; 
        }
    #largeImage{ 
        width:100%;
        height:auto;
        }
    #tp_thumbs img{ 
        float: left; 
        margin-right:5px; 
		margin-bottom:5px;
        width:100px; 
        height:80px; 
        }
    #description{ 
		background: none repeat scroll 0 0 black;
		bottom: 0;
		color: white;
		margin: 0;
		padding: 10px 20px;
		position: absolute;
		width: 93.5%; 
		opacity: 0.8;
		filter:Alpha(opacity=50); /* IE8 and earlier */
        }
    #tp_panel{ 
        position: relative; 
		width:;
		height:;
		overflow:hidden;
        }
    .tp_gallery_slider{
        width:100%;
        height:auto;
        padding:15px 0;
        margin:0 0 0 0;
        float:right;
        }
    </style>

		<!--[if lt IE 9]>
			<script src="http://whartonjournal.com/wp-content/themes/dw-focus/assets/js/html5.js" type="text/javascript"></script>
		<![endif]-->
		<style type="text/css">
		.top-news.loading .load
		{
  			display: none;
		}
/*		.dropdown-toggle.loading .read {
			display: none;
		}*/
				.site-header #branding a {
			background-image: url(http://whartonjournal.com/wp-content/uploads/2015/09/Logo8.jpg);
		}
		
				#colophon.dark #site-info .small-logo {
			background-image: url(http://whartonjournal.com/wp-content/uploads/2015/09/Mobile-Logo-4.jpg);
		}

		@media ( max-width: 979px ) {
			.wrap-navigation .small-logo {
				background-image: url(http://whartonjournal.com/wp-content/uploads/2015/09/Mobile-Logo-4.jpg);
			}
		}
		
		
				a:hover,
		.navbar .nav .current_page_item > a, 
		.navbar .nav .current-menu-item > a, 
		.navbar .nav .current-post-ancestor > a, 
		.navbar .nav .current-menu-parent > a, 
		.navbar .nav .current-menu-ancestor > a,

		.navbar .nav li a:hover, 
		.navbar .nav li a:active, 
		.navbar .nav li a:focus,

		.archive .content-inner .entry-meta a:hover,

		.desktop .top-news .dropdown-menu a:hover, 
		.desktop .top-news .dropdown-menu a:active, 
		.desktop .top-news .dropdown-menu a:focus,

		.home .site-content .content-inner .entry-meta a:hover {
			color: #a80c31;
		}

		.desktop .top-news .entry-meta,
		.news-slider .carousel .carousel-inner .entry-category,
		.nav-tabs>.active>a, .nav-tabs>.active>a:hover,
		.single .site-content>.hentry .post-categories li {
			background: #a80c31 !important   ;
		}

		.news-slider .carousel-list .other-entry li.active {
			border-left-color: #a80c31;
		}

		.nav-tabs>.active>a:before, .nav-tabs>.active>a:hover:before {
			border-top-color: #a80c31;
		}
		
		.archive .post-layout a.active,
		.pagination ul>li .current,
		.btn-primary:hover {
			background: #a80c31;
			border-color: #a80c31 !important;
		}

		body.error404 .entry-content h2 {
			color: #a80c31;
		}
		

			</style>
	<link rel="shortcut icon" href="http://whartonjournal.com/wp-content/themes/dw-focus/assets/img/favicon.ico">		<!-- Open Graph Meta Tags for Facebook and LinkedIn Sharing !-->
		<meta property="og:title" content="Wharton 2Y Embarrasses Famous Rapper on Stage and Saves 1000s of Lives in a Single Day"/>
		<meta property="og:description" content="" />
		<meta property="og:url" content="http://whartonjournal.com/2015/04/13/wharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2/"/>
						<meta property="og:image" content="http://whartonjournal.com/wp-content/uploads/2015/04/Varun-e1428943116747-110x103.jpg" />
		<meta property="og:type" content="article"
	/>
	<meta property="og:site_name" content="Wharton Journal"/>
	<!-- End Open Graph Meta Tags !-->

	<meta property="og:site_name" content="Wharton Journal" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="og:url" content="http://whartonjournal.com/2015/04/13/wharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2/" />
<meta property="og:title" content="Wharton 2Y Embarrasses Famous Rapper on Stage and Saves 1000s of Lives in a Single Day" />
<meta property="og:description" content="&nbsp; During the Fight Night After Party, MIMS pulled Vaurn Uttamchandani (WG’15) on stage and let him freestyle rap. The results were…well, see for yourself. That same night Uttamchandani took the One for the World pledge, promising to donate 1% of his income for the rest of his life to charitable organizations that have been selected for their&hellip;" />
<meta property="og:image" content="http://whartonjournal.com/wp-content/uploads/2015/04/Varun-e1428943116747.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="376" />
<meta property="article:published_time" content="2015-04-13T16:43:16+00:00" />
<meta property="article:modified_time" content="2015-04-13T23:46:17+00:00" />
<meta property="article:author" content="http://whartonjournal.com/author/whartonjournal/" />
<meta property="article:section" content="Features" />
</head>
<body class="single single-post postid-4542 single-format-standard desktop  not-login right-sidebar group-blog" >
	<header id="masthead" class="site-header" role="banner">
	    <div class="container">
	    	<div id="header">
	    		<div class="row">
	           		<div id="branding" class="span3 visible-desktop">
		                <h1>
		                	<a href="http://whartonjournal.com/" title="Wharton Journal" rel="home">
		                		Wharton Journal		                	</a>
		                </h1>
		            </div>
		            		        </div>
	        </div>
	        		            <div class="btn-group top-news lastest">
		            	<i class="fa fa-spinner fa-spin" style="font-size: 30px; display:none;"></i>
				    			<a class="dropdown-toggle" data-max="5" data-number="0" data-display="today" data-today="false" data-toggle="dropdown" href="#">
			<span class="number load">5</span>
			<span class="text load" style="display:block">Must read articles <i class="icon-caret-down"></i></span>
		</a>
						    </div>
			
		    <div class="wrap-navigation">
		        <nav id="site-navigation" class="main-navigation navbar" role="navigation">
		            <div class="navbar-inner">
						<button class="btn btn-navbar" data-target=".nav-collapse" data-toggle="collapse"  type="button">
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
						</button>

						<button class="collapse-search hidden-desktop" data-target=".search-collapse" data-toggle="collapse" >
							<i class="icon-search"></i>
						</button>

						<a class="small-logo hidden-desktop" rel="home" title="DW Focus" href="http://whartonjournal.com/">DW Focus</a>
					
												<ul class="social-links visible-desktop">
														<li class="facebook"><a target="_blank" href="https://www.facebook.com/TheWhartonJournal" title="Facebook"><i class="icon-facebook"></i></a></li>
																																																</ul><!-- End social links -->

						<div class="search-collapse collapse">
								<form method="get" name="searchForm" class="searchForm" action="http://whartonjournal.com/" role="search">
		<input type="text" class="field" name="s" value="" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" value="Search" />
	</form>
						</div>

						<div class="nav-collapse collapse">
							<ul id="menu-custom-menu" class="nav"><li id="menu-item-1860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1860 color-none menu-item-category-4 0"><a href="http://whartonjournal.com/category/news/" >News</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-1867" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1867 color-none menu-item-category-13 0"><a href="http://whartonjournal.com/category/leadership/" >Leadership</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-1870" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1870 color-none menu-item-category-7 0"><a href="http://whartonjournal.com/category/entrepreneurship-tech/" >Tech</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-2054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2054 color-none menu-item-category-18 0"><a href="http://whartonjournal.com/category/opinions/" >Opinions</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-2902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2902 color-none menu-item-category-24 0"><a href="http://whartonjournal.com/category/lifestyle/" >Lifestyle</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-2853" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2853 color-none menu-item-category-10 0"><a href="http://whartonjournal.com/category/perspectives/" >Perspectives</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-1872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1872 color-none menu-item-category-6 0"><a href="http://whartonjournal.com/category/philly/" >Philadelphia</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-2285" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2285 color-none menu-item-category-23 0"><a href="http://whartonjournal.com/category/wharton-diaries/" >Diaries</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-1864" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1864 color-none menu-item-category-5 0"><a href="http://whartonjournal.com/category/features/" >Features</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
</ul>						</div>	
		            </div>
		        </nav>

		        <div id="under-navigation" class="clearfix under-navigation">
		        	<div class="row-fluid">
		        				        		
						<div class="span3 offset9">	<form method="get" name="searchForm" class="searchForm" action="http://whartonjournal.com/" role="search">
		<input type="text" class="field" name="s" value="" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" value="Search" />
	</form>
</div>
					</div>
			    </div>
		    </div>
	    </div>
	</header> <!-- End header -->

	<div id="main">
         <div class="container">
             <div class="row">
     
        <div id="primary" class="site-content span12">
	
		
<article id="post-4542" class="post-4542 post type-post status-publish format-standard has-post-thumbnail hentry category-features content-print">
	<header class="entry-header">
		<h1 class="entry-title">Wharton 2Y Embarrasses Famous Rapper on Stage and Saves 1000s of Lives in a Single Day</h1>
		
		<div class="entry-meta">
			<a href="http://whartonjournal.com/author/whartonjournal/" title="Posts by The Wharton Journal" rel="author">The Wharton Journal</a><time class="entry-date" datetime="2015-04-13T12:43:16+00:00" pubdate>April 13, 2015</time><ul class="post-categories">
	<li><a href="http://whartonjournal.com/category/features/" rel="tag">Features</a></li></ul>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

			<div class="entry-thumbnail">
			<img width="400" height="376" src="http://whartonjournal.com/wp-content/uploads/2015/04/Varun-e1428943116747.jpg" class="attachment- wp-post-image" alt="Varun" />		</div>
	
	<div class="entry-content">
		
<div class="fb-social-plugin fb-like" data-ref="above-post" data-href="http://whartonjournal.com/2015/04/13/wharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2/" data-share="true" data-width="450"></div>
<p><a href="http://whartonjournal.com/wp-content/uploads/2015/04/Varun-e1428943116747.jpg" ><img class="size-full wp-image-4538 aligncenter" src="http://whartonjournal.com/wp-content/uploads/2015/04/Varun-e1428943116747.jpg" alt="Varun" width="400" height="376" /></a></p>
<p>&nbsp;</p>
<p>During the Fight Night After Party, MIMS pulled Vaurn Uttamchandani (WG’15) on stage and let him freestyle rap. The results were…well, see for yourself.</p>
<div style="width: 640px; " class="wp-video"><!--[if lt IE 9]><script>document.createElement('video');</script><![endif]-->
<video class="wp-video-shortcode" id="video-4542-1" width="640" height="360" preload="metadata" controls="controls"><source type="video/mp4" src="http://whartonjournal.com/wp-content/uploads/2015/04/OFTW-Rap-The-Night-Varun-Made-The-Pledge.mp4?_=1" /><a href="http://whartonjournal.com/wp-content/uploads/2015/04/OFTW-Rap-The-Night-Varun-Made-The-Pledge.mp4" >http://whartonjournal.com/wp-content/uploads/2015/04/OFTW-Rap-The-Night-Varun-Made-The-Pledge.mp4</a></video></div>
<p>That same night Uttamchandani took the One for the World pledge, promising to donate 1% of his income for the rest of his life to charitable organizations that have been selected for their effectiveness (e.g., 1% of a Wharton graduate’s income can treat over 1400 children per year for deadly tropical diseases). To learn more about One for the World, check out this article.</p>
<p><a href="http://whartonjournal.com/2015/03/02/one-for-the-world-a-practical-effective-approach-to-meaningful-philanthropy/" >http://whartonjournal.com/2015/03/02/one-for-the-world-a-practical-effective-approach-to-meaningful-philanthropy/</a></p>
<p><a href="http://whartonjournal.com/wp-content/uploads/2015/04/Varun-Poster-e1428942793529.jpg" ><img class="aligncenter wp-image-4540" src="http://whartonjournal.com/wp-content/uploads/2015/04/Varun-Poster-e1428942793529.jpg" alt="Varun Poster" width="400" height="554" /></a></p>
<hr />
<p>Check out more from the Wharton Journal, and like us <a href="https://www.facebook.com/TheWhartonJournal" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://www.facebook.com']);">on Facebook</a> or follow us <a href="https://twitter.com/whartonjournal" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">on Twitter</a>:</p>
<ul>
<li><a title="Do’s and Don’ts of GroupMe and Venmo Etiquette" href="http://whartonjournal.com/2015/04/12/dos-and-donts-of-groupme-and-venmo-etiquette/?source=article"  target="_blank">Do’s and Don’ts of GroupMe and Venmo Etiquette</a></li>
<li><a title="Brian Rikuda’s Guide to Success" href="http://whartonjournal.com/2015/04/12/brian-rikudas-guide-to-success/?source=article"  target="_blank">Brian Rikuda’s Guide to Success</a></li>
<li><a title="Commuting Guidance for the Class of 2017" href="http://whartonjournal.com/2015/04/13/commuting-guidance-for-the-class-of-2017/?source=article"  target="_blank">Commuting Guidance for the Class of 2017</a></li>
</ul>
<hr />

<div class="fb-social-plugin fb-like" data-ref="below-post" data-href="http://whartonjournal.com/2015/04/13/wharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2/" data-share="true" data-width="450"></div>
			</div><!-- .entry-content -->

			<div class="entry-action">
			<div class="social-action" data-nonce="5852a88e93">
				<span class="title-action">Sharing</span>
				<ul>
					<li id="twitter-share" class="twitter" data-post-id="4542" data-nonce="84284324d6"><i class="icon-twitter"></i><a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwhartonjournal.com%2F2015%2F04%2F13%2Fwharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2%2F&amp;text=Wharton+2Y+Embarrasses+Famous+Rapper+on+Stage+and+Saves+1000s+of+Lives+in+a+Single+Day">Twitter</a><span class="digit digit-twitter">0</span></li>
					<li class="facebook"><i class="icon-facebook-sign"></i><a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwhartonjournal.com%2F2015%2F04%2F13%2Fwharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2%2F&amp;t=Wharton+2Y+Embarrasses+Famous+Rapper+on+Stage+and+Saves+1000s+of+Lives+in+a+Single+Day" >Facebook</a><span class="digit digit-facebook">0</span></li>
					<li class="google"><i class="icon-google-plus-sign"></i><a href="https://plus.google.com/share?url=http%3A%2F%2Fwhartonjournal.com%2F2015%2F04%2F13%2Fwharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2%2F" >Google +</a><span>0</span></li>
					<li class="linkedin"><i class="icon-linkedin-sign"></i><a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fwhartonjournal.com%2F2015%2F04%2F13%2Fwharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2%2F&amp;title=Wharton+2Y+Embarrasses+Famous+Rapper+on+Stage+and+Saves+1000s+of+Lives+in+a+Single+Day&amp;summary=%26nbsp%3B%20During%20the%20Fight%20Night%20After%20Party%2C%20MIMS%C2%A0pulled%20Vaurn%20Uttamchandani%C2%A0%28WG%E2%80%9915%29%20on%20stage%20and%20let%20him%20freestyle%20rap.%20The%20results%20were%E2%80%A6well%2C%20see%20for%20yourself.%20That%20same%20night%C2%A0Uttamchandani%20took%20the%20One%20for%20the%20World%20pledge%2C%20promising%20to%20donate%201%25%20of%20his%20income%20for%20the%20rest%20of%20his%20life%20to%20charitable%20organizations%20that%20have%20been%20selected%20for%20their%3Ca%20href%3D%22http%3A%2F%2Fwhartonjournal.com%2F2015%2F04%2F13%2Fwharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2%2F%22%20title%3D%22Read%20more%22%20%3E...%3C%2Fa%3E">Linkedin</a><span class="digit digit-linkedin">0</span></li>
					<li class="email"><i class="icon-envelope-alt"></i><a href="mailto:?Subject=Wharton+2Y+Embarrasses+Famous+Rapper+on+Stage+and+Saves+1000s+of+Lives+in+a+Single+Day&amp;body=http%3A%2F%2Fwhartonjournal.com%2F2015%2F04%2F13%2Fwharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2%2F">Email this article</a></li>
										<li class="print"><i class="icon-print"></i><a href="#" onclick="window.print();">Print this article</a></li>
									</ul>
			</div>

							<div class="co-author">
				<span class="title-action">Authors</span>
				
					<div class="author-info">
						<img alt='' src='http://1.gravatar.com/avatar/196ff34e9266b8d6a970ba3cd8a9f29b?s=96&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/196ff34e9266b8d6a970ba3cd8a9f29b?s=192&amp;d=mm&amp;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' />						<a foo="baz" class="author-name" href="http://whartonjournal.com/author/whartonjournal/" rel="author">The Wharton Journal</a></h2>
					</div><!-- .author-info -->

								</div>
			
			 		</div>
		
</article><!-- #post-4542 -->
		

	
		
		
			

<div id="comments" class="comments-area">

		
			<h3 class="comments-title">
			51 Comments		</h3>

		
		<ol class="commentlist">
				<li class="post pingback">
		<p>Pingback: <a href="http://www.bluecoasterfuncrowd33.com/3jjkkkkk" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.bluecoasterfuncrowd33.com']);"  rel='external nofollow' class='url'>Blue Coaster33</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://hpstream.com/series/55204-the-100" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://hpstream.com']);"  rel='external nofollow' class='url'>watch movies online</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://hpstream.com/movies?_escaped_fragment_=1&#038;page=844" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://hpstream.com']);"  rel='external nofollow' class='url'>stream movies</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.xwicked.com/pretty-dark-haired-doubled-dicked-312308.html" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.xwicked.com']);"  rel='external nofollow' class='url'>Pretty dark-haired doubled dicked</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.tvpackages.net/directv-vs-cable.html" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.tvpackages.net']);"  rel='external nofollow' class='url'>Direct TV vs Cable TV</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.tvpackages.net/directv-satellite-tv.html" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.tvpackages.net']);"  rel='external nofollow' class='url'>get satellite tv</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.fue.mobi" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.fue.mobi']);"  rel='external nofollow' class='url'>fue.mobi</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://tinyurl.com/l267prm" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://tinyurl.com']);"  rel='external nofollow' class='url'>lan penge nu uden renter</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.stopaceparking.com" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.stopaceparking.com']);"  rel='external nofollow' class='url'>parking</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://bit.ly/1bChex1" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://bit.ly']);"  rel='external nofollow' class='url'>laan penge</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="https://www.alkalinewaterplus.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','']);"  rel='external nofollow' class='url'>water ionizers</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://stopaceparking.com" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://stopaceparking.com']);"  rel='external nofollow' class='url'>parking</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://youtube.blogspace.be/off-276321/ce2dcf223458bc2168e61f0b5e3aa67d/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://youtube.blogspace.be']);"  rel='external nofollow' class='url'>YouTube favorites kopen</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="https://alkalinewaterplus.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','']);"  rel='external nofollow' class='url'>water ionizer loans</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="https://alkalinewaterplus.com/analyzing-comparing-bottled-water/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','']);"  rel='external nofollow' class='url'>bottled alkaline water</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://swardhara.com/index.php/component/k2/itemlist/user/69282" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://swardhara.com']);"  rel='external nofollow' class='url'>electrician apprenticeship california</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.opticalopez.com.ar/index.php/component/k2/itemlist/user/39233" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.opticalopez.com.ar']);"  rel='external nofollow' class='url'>read full report</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.intermark.com.py/?option=com_k2&#038;view=itemlist&#038;task=user&#038;id=112519" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.intermark.com.py']);"  rel='external nofollow' class='url'>locksmiths in the area</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.100schloesserroute.de/?option=com_k2&#038;view=itemlist&#038;task=user&#038;id=70991" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.100schloesserroute.de']);"  rel='external nofollow' class='url'>that site</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://centroscepi.com/index.php/component/k2/itemlist/user/48645" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://centroscepi.com']);"  rel='external nofollow' class='url'>plummers relish factory</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://kle3ndance.com/index.php/component/k2/itemlist/user/41001" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://kle3ndance.com']);"  rel='external nofollow' class='url'>blackman plumbing medford</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.bazafirm.org/szklarze-b320/refleks_zaklad_szklarski-f82711" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.bazafirm.org']);"  rel='external nofollow' class='url'>zakład szklarski piotrków trybunalski</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.refrigeratorbrowncargreycarbluerec.com/3jkjdkk" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.refrigeratorbrowncargreycarbluerec.com']);"  rel='external nofollow' class='url'>house blue</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://cours-pilates-cours-danse-orientale-nimes-arles.ghania-ilha.fr/?option=com_k2&#038;view=itemlist&#038;task=user&#038;id=213972" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://cours-pilates-cours-danse-orientale-nimes-arles.ghania-ilha.fr']);"  rel='external nofollow' class='url'>klein electrician tool set</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.automerc-autobusy.pl/?option=com_k2&#038;view=itemlist&#038;task=user&#038;id=115555" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.automerc-autobusy.pl']);"  rel='external nofollow' class='url'>d magazine best electricians</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="https://alkalinewaterplus.com/water-ionizer-comparisons/loan" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','']);"  rel='external nofollow' class='url'>payment plan</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="https://alkalinewaterplus.com/store/payplans/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','']);"  rel='external nofollow' class='url'>pay per day loan plans</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="https://alkalinewaterplus.com/free-pay-plans/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','']);"  rel='external nofollow' class='url'>pay per day loans plan</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="https://alkalinewaterplus.com/water-ionizer-comparisons/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','']);"  rel='external nofollow' class='url'>loan payment plan</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://pandora.nla.gov.au/external.html?link=http://goo.gl/EZVYoo" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://pandora.nla.gov.au']);"  rel='external nofollow' class='url'>pennsylvania energy choices</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="https://www.aqualiv.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','']);"  rel='external nofollow' class='url'>alkaline water</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.doleta.gov/regions/reg05/Pages/exit.cfm?vexit=http://goo.gl/cQU8zw" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.doleta.gov']);"  rel='external nofollow' class='url'>read more</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://thecityfinancial.com/i-have-to-give-you-an-insiders-view-into-free-casino-games-bonus/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://thecityfinancial.com']);"  rel='external nofollow' class='url'>over here</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.homestaging-shop.biz/play-slots-is-great-for-attracting-business-too/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.homestaging-shop.biz']);"  rel='external nofollow' class='url'>link</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.iate89.ru/info.php?a%5B%5D=%3Ca+href%3Dhttps%3A%2F%2Fplus.google.com%2F112836327386954605611%2Fabout%3Elustra%3C%2Fa%3E" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.iate89.ru']);"  rel='external nofollow' class='url'>budowa</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://migre.me/rnBUo" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://migre.me']);"  rel='external nofollow' class='url'>tier2</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://xn--26-9kcpabdk8ayic5c.xn--p1ai/?option=com_k2&#038;view=itemlist&#038;task=user&#038;id=328850" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://xn--26-9kcpabdk8ayic5c.xn--p1ai']);"  rel='external nofollow' class='url'>tier2 junk</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.ccn2785xdnwdc5bwedsj4wsndb.com" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.ccn2785xdnwdc5bwedsj4wsndb.com']);"  rel='external nofollow' class='url'>ccn2785xdnwdc5bwedsj4wsndb</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.3nvb54wnxd5cbvbecnv5ev75bc.com" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.3nvb54wnxd5cbvbecnv5ev75bc.com']);"  rel='external nofollow' class='url'>3nvb54wnxd5cbvbecnv5ev75bc</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.2xncq3tbooowtfb57wwc5m4tnt.com" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.2xncq3tbooowtfb57wwc5m4tnt.com']);"  rel='external nofollow' class='url'>2xncq3tbooowtfb57wwc5m4tnt</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.mxa4nctaxmznzdt5rtacwfsdffa.com" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.mxa4nctaxmznzdt5rtacwfsdffa.com']);"  rel='external nofollow' class='url'>mxa4nctaxmznzdt5rtacwfsdffa</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.xmct5895ct4jt3d4yxtjgwj45tc3j.com" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.xmct5895ct4jt3d4yxtjgwj45tc3j.com']);"  rel='external nofollow' class='url'>xmct5895ct4jt3d4yxtjgwj45tc3j</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.x30m85cgcr83n5rwxym8cnrsdfruxm.com" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.x30m85cgcr83n5rwxym8cnrsdfruxm.com']);"  rel='external nofollow' class='url'>x30m85cgcr83n5rwxym8cnrsdfruxm</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://gravitypicks.com" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://gravitypicks.com']);"  rel='external nofollow' class='url'>mandolin picks</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://topcheapinsurance.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://topcheapinsurance.com']);"  rel='external nofollow' class='url'>cheapest car insurance online</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://quotesautoinsurance.org/state-farm-quote.html" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://quotesautoinsurance.org']);"  rel='external nofollow' class='url'>state farm 1 800 number</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://justiciaypazcolombia.com/Una-viuda-lucha-por-la-justicia" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://justiciaypazcolombia.com']);"  rel='external nofollow' class='url'>carlos jose rios grajales</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.solidworkswiki.ru/index.php/The_Ins_And_Outs_Of_Community_Talking" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.solidworkswiki.ru']);"  rel='external nofollow' class='url'>pure silk</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="https://www.youtube.com/playlist?list=PLcvlhNK2FxiLULrCQ8Mu7VN_hqqSZkREa" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','']);"  rel='external nofollow' class='url'>skypepsyxologmoskvakiev</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://iphone-5-6-bu-ua.diorcom.ru/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://iphone-5-6-bu-ua.diorcom.ru']);"  rel='external nofollow' class='url'>saleforiphone</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href="http://www.gregthompson22.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-commentauthor','http://www.gregthompson22.com']);"  rel='external nofollow' class='url'>Greg Thmomson</a></p>
	</li><!-- #comment-## -->
		</ol><!-- .commentlist -->

		
	

	


							<div id="respond" class="comment-respond">
				<h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2015/04/13/wharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2/#respond" style="display:none;">Cancel reply</a></small></h3>
									<p class="must-log-in">You must be <a href="http://whartonjournal.com/wp-login.php?redirect_to=http%3A%2F%2Fwhartonjournal.com%2F2015%2F04%2F13%2Fwharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2%2F">logged in</a> to post a comment.</p>												</div><!-- #respond -->
			        <script type="text/javascript">
            jQuery(document).ready(function () {
                jQuery('#commentform').submit(function () {
                    _gaq.push(
                            ['_setAccount', 'UA-26359921-1'],
                            ['_trackEvent', 'comment', 'submit']
                    );
                });
            });
        </script>
		
</div><!-- #comments .comments-area -->
		</div>

  	
	    <div id="secondary" class="widget-area span3" role="complementary">
		<aside id="mostreadpostswidget-9" class="widget widget_mostreadpostswidget"><h3 class="widget-title">Most Read Posts</h3><ul class="mlrp_ul"><li>No results available</li></ul>
		<div style="clear:both;"></div></aside><aside id="text-4" class="widget widget_text"><h3 class="widget-title">Request Advertising Info</h3>			<div class="textwidget"><div class="wpcf7" id="wpcf7-f98-w1-o1"><form action="/2015/04/13/wharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2/#wpcf7-f98-w1-o1" method="post" class="wpcf7-form">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="98" />
<input type="hidden" name="_wpcf7_version" value="3.3.1" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f98-w1-o1" />
<input type="hidden" name="_wpnonce" value="72b3023d1f" />
</div>
<p>Your Name (required)<br />
    <span class="wpcf7-form-control-wrap your-name"><input type="text" name="your-name" value="" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" size="40" /></span> </p>
<p>Your Email (required)<br />
    <span class="wpcf7-form-control-wrap your-email"><input type="text" name="your-email" value="" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" size="40" /></span> </p>
<p>Subject<br />
    <span class="wpcf7-form-control-wrap your-subject"><input type="text" name="your-subject" value="" class="wpcf7-form-control wpcf7-text" size="40" /></span> </p>
<p>Your Message<br />
    <span class="wpcf7-form-control-wrap your-message"><textarea name="your-message" class="wpcf7-form-control  wpcf7-textarea" cols="40" rows="10"></textarea></span> </p>
<p><input type="submit" value="Send" class="wpcf7-form-control  wpcf7-submit" /></p>
<div class="wpcf7-response-output wpcf7-display-none"></div></form></div></div>
		</aside><aside id="text-5" class="widget widget_text"><h3 class="widget-title">Contact the Editors</h3>			<div class="textwidget"><div class="wpcf7" id="wpcf7-f35-w2-o1"><form action="/2015/04/13/wharton-2y-embarrasses-famous-rapper-on-stage-and-saves-1000s-of-lives-in-a-single-day-2/#wpcf7-f35-w2-o1" method="post" class="wpcf7-form">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="35" />
<input type="hidden" name="_wpcf7_version" value="3.3.1" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f35-w2-o1" />
<input type="hidden" name="_wpnonce" value="9963f04be5" />
</div>
<p>Your Name (required)<br />
    <span class="wpcf7-form-control-wrap your-name"><input type="text" name="your-name" value="" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" size="40" /></span> </p>
<p>Your Email (required)<br />
    <span class="wpcf7-form-control-wrap your-email"><input type="text" name="your-email" value="" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" size="40" /></span> </p>
<p>Subject<br />
    <span class="wpcf7-form-control-wrap your-subject"><input type="text" name="your-subject" value="" class="wpcf7-form-control wpcf7-text" size="40" /></span> </p>
<p>Your Message<br />
    <span class="wpcf7-form-control-wrap your-message"><textarea name="your-message" class="wpcf7-form-control  wpcf7-textarea" cols="40" rows="10"></textarea></span> </p>
<p><input type="submit" value="Send" class="wpcf7-form-control  wpcf7-submit" /></p>
<div class="wpcf7-response-output wpcf7-display-none"></div></form></div></div>
		</aside>	</div>
	            </div>
         </div>
     </div>

    
    <!-- Footer -->
    <footer id="colophon" class="site-footer dark" role="contentinfo">
        <div class="container">

            <div id="site-tools">
                <div class="row-fluid">
                    <div class="span9"><ul class="breadcrumbs"><li itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="http://whartonjournal.com"><span itemprop="title">Wharton Journal</span></a> </li> <li itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="http://whartonjournal.com/category/features/"><span itemprop="title">Features</span></a></li><li> Wharton 2Y Embarrasses Famous Rapper on Stage and Saves 1000s of Lives in a Single Day</li></ul></div>
                                    </div>
            </div>

            
            <div class="footer-shadown"></div>
        </div>

        <div id="site-info" class="container">
            <div class="clearfix">
                <div class="copyright">
                    <p>Copyright &copy; 2012 by <a href="http://demo.designwall.com/dw-focus/" title="DW Focus" rel="nofollow">DW Focus</a>. Proudly powered by <a href="http://wordpress.org/" title="Semantic Personal Publishing Platform">WordPress</a></p>
                    <p><a title="Responsive WordPress Themes for Free and Premium" href="http://designwall.com/" rel="nofollow">WordPress Theme by DesignWall</a></p>
                </div>
                <div class="logo">
                    <a class="small-logo" href="http://whartonjournal.com/" title="Wharton Journal" rel="home">Wharton Journal</a>
                </div>
            </div>
        </div>
    </footer><!-- #colophon .site-footer -->
<a class="scroll-top" href="#masthead" title="Scroll to top">Top</a>
<script type="text/javascript">
				jQuery("#tp_thumbs").delegate("img","hover", function(){
				jQuery("#largeImage").attr("src",jQuery(this).attr("src").replace("thumb","large"));
				jQuery("#description").html(jQuery(this).attr("alt"));
			});
		  </script><link rel='stylesheet' id='mediaelement-css'  href='http://whartonjournal.com/wp-includes/js/mediaelement/mediaelementplayer.min.css?ver=2.17.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='http://whartonjournal.com/wp-includes/js/mediaelement/wp-mediaelement.css?ver=4.3.7' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/whartonjournal.com\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","sending":"Sending ..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=3.3.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="http:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
<script type='text/javascript'>
/* <![CDATA[ */
var mejsL10n = {"language":"en-US","strings":{"Close":"Close","Fullscreen":"Fullscreen","Download File":"Download File","Download Video":"Download Video","Play\/Pause":"Play\/Pause","Mute Toggle":"Mute Toggle","None":"None","Turn off Fullscreen":"Turn off Fullscreen","Go Fullscreen":"Go Fullscreen","Unmute":"Unmute","Mute":"Mute","Captions\/Subtitles":"Captions\/Subtitles"}};
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://whartonjournal.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=2.17.0-a'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-includes/js/mediaelement/wp-mediaelement.js?ver=4.3.7'></script>
<div id="fb-root"></div></body>
</html>