<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta content="width=device-width, initial-scale=1.0, user-scalable=no" name="viewport">
<title>Welcome the New Editors | Wharton Journal</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://whartonjournal.com/xmlrpc.php" />

<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel="alternate" type="application/rss+xml" title="Wharton Journal &raquo; Feed" href="http://whartonjournal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Wharton Journal &raquo; Comments Feed" href="http://whartonjournal.com/comments/feed/" />

            <script type="text/javascript">//<![CDATA[
            // Google Analytics for WordPress by Yoast v4.3.5 | http://yoast.com/wordpress/google-analytics/
            var _gaq = _gaq || [];
            _gaq.push(['_setAccount', 'UA-26359921-1']);
				            _gaq.push(['_trackPageview']);
            (function () {
                var ga = document.createElement('script');
                ga.type = 'text/javascript';
                ga.async = true;
                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';

                var s = document.getElementsByTagName('script')[0];
                s.parentNode.insertBefore(ga, s);
            })();
            //]]></script>
			<link rel="alternate" type="application/rss+xml" title="Wharton Journal &raquo; Welcome the New Editors Comments Feed" href="http://whartonjournal.com/2017/04/22/welcome-the-new-editors/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"http:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/whartonjournal.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.3.10"}};
			!function(a,b,c){function d(a){var c=b.createElement("canvas"),d=c.getContext&&c.getContext("2d");return d&&d.fillText?(d.textBaseline="top",d.font="600 32px Arial","flag"===a?(d.fillText(String.fromCharCode(55356,56812,55356,56807),0,0),c.toDataURL().length>3e3):(d.fillText(String.fromCharCode(55357,56835),0,0),0!==d.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='flick-css'  href='http://whartonjournal.com/wp-content/plugins/mailchimp//css/flick/flick.css?ver=4.3.10' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimpSF_main_css-css'  href='http://whartonjournal.com/?mcsf_action=main_css&#038;ver=4.3.10' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='mailchimpSF_ie_css-css'  href='http://whartonjournal.com/wp-content/plugins/mailchimp/css/ie.css?ver=4.3.10' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='contact-form-7-css'  href='http://whartonjournal.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=3.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='recent-facebook-posts-css-css'  href='http://whartonjournal.com/wp-content/plugins/recent-facebook-posts/assets/css/default.min.css?ver=2.0.11' type='text/css' media='all' />
<link rel='stylesheet' id='dw_focus_template-css'  href='http://whartonjournal.com/wp-content/themes/dw-focus/assets/css/dw-focus.min.css?ver=4.3.10' type='text/css' media='all' />
<link rel='stylesheet' id='dw_focus_responsive-css'  href='http://whartonjournal.com/wp-content/themes/dw-focus/assets/css/dw-focus-responsive.min.css?ver=4.3.10' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='http://whartonjournal.com/wp-content/themes/dw-focus/style.css?ver=4.3.10' type='text/css' media='all' />
<link rel='stylesheet' id='print-style-css'  href='http://whartonjournal.com/wp-content/themes/dw-focus/assets/css/print.css?ver=4.3.10' type='text/css' media='print' />
<link rel='stylesheet' id='dw-focus-qa-css'  href='http://whartonjournal.com/wp-content/themes/dw-focus/dwqa-templates/style.css?ver=4.3.10' type='text/css' media='all' />
<link rel='stylesheet' id='attachment-css-css'  href='http://whartonjournal.com/wp-content/plugins/document-attachment-widget/css/attachment_widget.css?ver=4.3.10' type='text/css' media='all' />
<script type='text/javascript' src='http://whartonjournal.com/wp-includes/js/jquery/jquery.js?ver=1.11.3'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/plugins/mailchimp/js/scrollTo.js?ver=1.2.10'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.18'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mailchimpSF = {"ajax_url":"http:\/\/whartonjournal.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/plugins/mailchimp/js/mailchimp.js?ver=1.2.10'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/plugins/mailchimp//js/datepicker.js?ver=4.3.10'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/themes/dw-focus/assets/js/jquery.mouse.move.js?ver=4.3.10'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/themes/dw-focus/assets/js/jquery.swipe.js?ver=4.3.10'></script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/themes/dw-focus/assets/js/jquery.infinitescroll.min.js?ver=4.3.10'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"http:\/\/whartonjournal.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/themes/dw-focus/assets/js/dw-focus.min.js?ver=4.3.10'></script>
<script type='text/javascript' src='//platform.twitter.com/widgets.js?ver=4.3.10'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://whartonjournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://whartonjournal.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='What&#8217;s Similar Between Holi and Wharton Experience' href='http://whartonjournal.com/2017/04/22/whats-similar-between-holi-and-wharton-experience/' />
<link rel='next' title='Make the Most of Your Summer Internship' href='http://whartonjournal.com/2017/04/22/make-the-most-of-your-summer-internship/' />
<meta name="generator" content="WordPress 4.3.10" />
<link rel='canonical' href='http://whartonjournal.com/2017/04/22/welcome-the-new-editors/' />
<link rel='shortlink' href='http://whartonjournal.com/?p=6366' />
<script type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-26359921-1']);
_gaq.push(['_trackPageview']);
(function() {
var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
	<script type="text/javascript">
		jQuery(function($) {
			$('.date-pick').datepicker({
				autoFocusNextInput: true,
				constrainInput: false,
				changeMonth: true,
				changeYear: true,
				beforeShow: function(input, inst) { $('#ui-datepicker-div').addClass('show'); },
				dateFormat: 'yy/mm/dd',
			});			
			
			d = new Date();
			$('.birthdate-pick').datepicker({
				autoFocusNextInput: true,
				constrainInput: false,
				changeMonth: true,
				changeYear: false,
				minDate: new Date(d.getFullYear(), 1-1, 1),
				maxDate: new Date(d.getFullYear(), 12-1, 31),
				beforeShow: function(input, inst) { $('#ui-datepicker-div').removeClass('show'); },
				dateFormat: 'mm/dd',
			});
			
				
		});
	</script>
	    
    <style type="text/css">
    #tp_thumbs{ 
        padding-top: 10px; 
        overflow: hidden; 
        }
    #largeImage{ 
        width:100%;
        height:auto;
        }
    #tp_thumbs img{ 
        float: left; 
        margin-right:5px; 
		margin-bottom:5px;
        width:100px; 
        height:80px; 
        }
    #description{ 
		background: none repeat scroll 0 0 black;
		bottom: 0;
		color: white;
		margin: 0;
		padding: 10px 20px;
		position: absolute;
		width: 93.5%; 
		opacity: 0.8;
		filter:Alpha(opacity=50); /* IE8 and earlier */
        }
    #tp_panel{ 
        position: relative; 
		width:;
		height:;
		overflow:hidden;
        }
    .tp_gallery_slider{
        width:100%;
        height:auto;
        padding:15px 0;
        margin:0 0 0 0;
        float:right;
        }
    </style>

		<!--[if lt IE 9]>
			<script src="http://whartonjournal.com/wp-content/themes/dw-focus/assets/js/html5.js" type="text/javascript"></script>
		<![endif]-->
		<style type="text/css">
		.top-news.loading .load
		{
  			display: none;
		}
/*		.dropdown-toggle.loading .read {
			display: none;
		}*/
				.site-header #branding a {
			background-image: url(http://whartonjournal.com/wp-content/uploads/2015/09/Logo8.jpg);
		}
		
				#colophon.dark #site-info .small-logo {
			background-image: url(http://whartonjournal.com/wp-content/uploads/2015/09/Mobile-Logo-4.jpg);
		}

		@media ( max-width: 979px ) {
			.wrap-navigation .small-logo {
				background-image: url(http://whartonjournal.com/wp-content/uploads/2015/09/Mobile-Logo-4.jpg);
			}
		}
		
		
				a:hover,
		.navbar .nav .current_page_item > a, 
		.navbar .nav .current-menu-item > a, 
		.navbar .nav .current-post-ancestor > a, 
		.navbar .nav .current-menu-parent > a, 
		.navbar .nav .current-menu-ancestor > a,

		.navbar .nav li a:hover, 
		.navbar .nav li a:active, 
		.navbar .nav li a:focus,

		.archive .content-inner .entry-meta a:hover,

		.desktop .top-news .dropdown-menu a:hover, 
		.desktop .top-news .dropdown-menu a:active, 
		.desktop .top-news .dropdown-menu a:focus,

		.home .site-content .content-inner .entry-meta a:hover {
			color: #a80c31;
		}

		.desktop .top-news .entry-meta,
		.news-slider .carousel .carousel-inner .entry-category,
		.nav-tabs>.active>a, .nav-tabs>.active>a:hover,
		.single .site-content>.hentry .post-categories li {
			background: #a80c31 !important   ;
		}

		.news-slider .carousel-list .other-entry li.active {
			border-left-color: #a80c31;
		}

		.nav-tabs>.active>a:before, .nav-tabs>.active>a:hover:before {
			border-top-color: #a80c31;
		}
		
		.archive .post-layout a.active,
		.pagination ul>li .current,
		.btn-primary:hover {
			background: #a80c31;
			border-color: #a80c31 !important;
		}

		body.error404 .entry-content h2 {
			color: #a80c31;
		}
		

			</style>
	<link rel="shortcut icon" href="http://whartonjournal.com/wp-content/themes/dw-focus/assets/img/favicon.ico">		<!-- Open Graph Meta Tags for Facebook and LinkedIn Sharing !-->
		<meta property="og:title" content="Welcome the New Editors"/>
		<meta property="og:description" content="" />
		<meta property="og:url" content="http://whartonjournal.com/2017/04/22/welcome-the-new-editors/"/>
						<meta property="og:image" content="http://whartonjournal.com/wp-content/uploads/2017/04/Slide1-110x83.jpg" />
		<meta property="og:type" content="article"
	/>
	<meta property="og:site_name" content="Wharton Journal"/>
	<!-- End Open Graph Meta Tags !-->

	<meta property="og:site_name" content="Wharton Journal" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="og:url" content="http://whartonjournal.com/2017/04/22/welcome-the-new-editors/" />
<meta property="og:title" content="Welcome the New Editors" />
<meta property="og:description" content="Name: Emmanuel Chimezie Title: Editor-In-Chief Best &amp; worst moment at Wharton so far: Best: Seeing Clyde open for Yung Joc. Worst: Spending too much time on CS Vision for WJ: The Wharton Journal has a long history and I hope to contribute what I can to a great brand - by increasing readership among current&hellip;" />
<meta property="og:image" content="http://whartonjournal.com/wp-content/uploads/2017/04/Slide1.jpg" />
<meta property="og:image:width" content="720" />
<meta property="og:image:height" content="540" />
<meta property="og:image" content="http://whartonjournal.com/wp-content/uploads/2017/04/Qian-Lixia_009_1.jpg" />
<meta property="og:image:width" content="1600" />
<meta property="og:image:height" content="1066" />
<meta property="og:image" content="http://whartonjournal.com/wp-content/uploads/2017/04/Abhishek.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="400" />
<meta property="article:published_time" content="2017-04-22T18:27:03+00:00" />
<meta property="article:modified_time" content="2017-04-22T18:27:03+00:00" />
<meta property="article:author" content="http://whartonjournal.com/author/whartonjournal/" />
<meta property="article:section" content="Clubs" />
<meta property="article:tag" content="Leadership" />
</head>
<body class="single single-post postid-6366 single-format-standard desktop  not-login right-sidebar group-blog" >
	<header id="masthead" class="site-header" role="banner">
	    <div class="container">
	    	<div id="header">
	    		<div class="row">
	           		<div id="branding" class="span3 visible-desktop">
		                <h1>
		                	<a href="http://whartonjournal.com/" title="Wharton Journal" rel="home">
		                		Wharton Journal		                	</a>
		                </h1>
		            </div>
		            		        </div>
	        </div>
	        		            <div class="btn-group top-news lastest">
		            	<i class="fa fa-spinner fa-spin" style="font-size: 30px; display:none;"></i>
				    			<a class="dropdown-toggle" data-max="5" data-number="0" data-display="today" data-today="false" data-toggle="dropdown" href="#">
			<span class="number load">5</span>
			<span class="text load" style="display:block">Must read articles <i class="icon-caret-down"></i></span>
		</a>
						    </div>
			
		    <div class="wrap-navigation">
		        <nav id="site-navigation" class="main-navigation navbar" role="navigation">
		            <div class="navbar-inner">
						<button class="btn btn-navbar" data-target=".nav-collapse" data-toggle="collapse"  type="button">
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
							<span class="icon-bar"></span>
						</button>

						<button class="collapse-search hidden-desktop" data-target=".search-collapse" data-toggle="collapse" >
							<i class="icon-search"></i>
						</button>

						<a class="small-logo hidden-desktop" rel="home" title="DW Focus" href="http://whartonjournal.com/">DW Focus</a>
					
												<ul class="social-links visible-desktop">
														<li class="facebook"><a target="_blank" href="https://www.facebook.com/TheWhartonJournal" title="Facebook"><i class="icon-facebook"></i></a></li>
																																																</ul><!-- End social links -->

						<div class="search-collapse collapse">
								<form method="get" name="searchForm" class="searchForm" action="http://whartonjournal.com/" role="search">
		<input type="text" class="field" name="s" value="" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" value="Search" />
	</form>
						</div>

						<div class="nav-collapse collapse">
							<ul id="menu-custom-menu" class="nav"><li id="menu-item-1860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1860 color-none menu-item-category-4 0"><a href="http://whartonjournal.com/category/news/" >News</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-1867" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1867 color-none menu-item-category-13 0"><a href="http://whartonjournal.com/category/leadership/" >Leadership</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-1870" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1870 color-none menu-item-category-7 0"><a href="http://whartonjournal.com/category/entrepreneurship-tech/" >Tech</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-2054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2054 color-none menu-item-category-18 0"><a href="http://whartonjournal.com/category/opinions/" >Opinions</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-2902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2902 color-none menu-item-category-24 0"><a href="http://whartonjournal.com/category/lifestyle/" >Lifestyle</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-2853" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2853 color-none menu-item-category-10 0"><a href="http://whartonjournal.com/category/perspectives/" >Perspectives</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-1872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1872 color-none menu-item-category-6 0"><a href="http://whartonjournal.com/category/philly/" >Philadelphia</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-2285" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2285 color-none menu-item-category-23 0"><a href="http://whartonjournal.com/category/wharton-diaries/" >Diaries</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
<li id="menu-item-1864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1864 color-none menu-item-category-5 0"><a href="http://whartonjournal.com/category/features/" >Features</a><div class="sub-mega-wrap">
<div class='subcat'></div> 
</div>
</li>
</ul>						</div>	
		            </div>
		        </nav>

		        <div id="under-navigation" class="clearfix under-navigation">
		        	<div class="row-fluid">
		        				        		
						<div class="span3 offset9">	<form method="get" name="searchForm" class="searchForm" action="http://whartonjournal.com/" role="search">
		<input type="text" class="field" name="s" value="" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" value="Search" />
	</form>
</div>
					</div>
			    </div>
		    </div>
	    </div>
	</header> <!-- End header -->

	<div id="main">
         <div class="container">
             <div class="row">
     
        <div id="primary" class="site-content span12">
	
		
<article id="post-6366" class="post-6366 post type-post status-publish format-standard has-post-thumbnail hentry category-clubs category-leadership content-print">
	<header class="entry-header">
		<h1 class="entry-title">Welcome the New Editors</h1>
		
		<div class="entry-meta">
			<a href="http://whartonjournal.com/author/whartonjournal/" title="Posts by The Wharton Journal" rel="author">The Wharton Journal</a><time class="entry-date" datetime="2017-04-22T14:27:03+00:00" pubdate>April 22, 2017</time><ul class="post-categories">
	<li><a href="http://whartonjournal.com/category/clubs/" rel="tag">Clubs</a></li>
	<li><a href="http://whartonjournal.com/category/leadership/" rel="tag">Leadership</a></li></ul>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

			<div class="entry-thumbnail">
			<img width="720" height="540" src="http://whartonjournal.com/wp-content/uploads/2017/04/Slide1.jpg" class="attachment- wp-post-image" alt="Slide1" />		</div>
	
	<div class="entry-content">
		
<div class="fb-social-plugin fb-like" data-ref="above-post" data-href="http://whartonjournal.com/2017/04/22/welcome-the-new-editors/" data-share="true" data-width="450"></div>
<p><strong>Name:</strong> Emmanuel Chimezie</p>
<p><strong>Title:</strong> Editor-In-Chief</p>
<p><strong>Best &amp; worst moment at Wharton so far: Best</strong>: Seeing Clyde open for Yung Joc. Worst: Spending too much time on CS</p>
<p><strong>Vision for WJ:</strong> The Wharton Journal has a long history and I hope to contribute what I can to a great brand &#8211; by increasing readership among current students (EMBA and Full-time) and alumni, innovating on new models of content distribution, and increasing the digital footprint.</p>
<p>&nbsp;</p>
<p><strong>Name:</strong> Felicia Lixia Qian</p>
<p><strong>Title:</strong> Editor-in-Chief</p>
<p><strong>Best &amp; worst moment at Wharton so far:</strong> Best: Any moment a classmate shared a story or did something that inspired me &#8211; that made me proud and thankful to be part of this awesome community.</p>
<p><strong>Worst:</strong> Some day in Q2 when I was overwhelmed by recruiting and everything else happening.</p>
<p>Vision for WJ:  Build WJ an open and trustful platform that people will think about in the first place when they want to voice any opinion. Make essential contributions in making our community more inclusive and powerful. Enhance its online presence and visibility with high-quality contents and interactions.</p>
<p>&nbsp;</p>
<p><strong>Name:</strong> Abhishek Patel</p>
<p><strong>Title:</strong> Executive Editor</p>
<p><strong>Best &amp; worst moment at Wharton so far:</strong> Best: Successful completion of the Atacama Venture. Worst: Academics (Thank God for Grade non-disclosure)</p>
<p><strong>Vision for WJ:</strong> Build the Wharton Journal Brand &#8211; Informative &amp; Investigative. More active involvement from alumni and developing content across industries. Scaling up viewership/readers.</p>
<p>&nbsp;</p>
<p><strong>Name:</strong> Deepika Priyadarshini</p>
<p><strong>Title:</strong> Digital Editor</p>
<p><strong>Best &amp; worst moment at Wharton so far:</strong> My favorite moment was the Wharton Olympics: a super-hot day with temperatures hitting an extreme of 100 F but still all of us out in open competing for cluster points while forming those initial bonds. Worst: The first week of Q2 &#8211; with early morning coffee chats and late night networking events leaving no time to see my daughter.</p>
<p><strong>Vision for WJ:</strong> I want to make Wharton Journal a part of your life: printed version in hands of every student and the digital platform as one of the most visited website.  My vision is to make the digital version an interactive way to build the community.</p>

<div class="fb-social-plugin fb-like" data-ref="below-post" data-href="http://whartonjournal.com/2017/04/22/welcome-the-new-editors/" data-share="true" data-width="450"></div>
			</div><!-- .entry-content -->

			<div class="entry-action">
			<div class="social-action" data-nonce="3cadf5f5d1">
				<span class="title-action">Sharing</span>
				<ul>
					<li id="twitter-share" class="twitter" data-post-id="6366" data-nonce="631b857b61"><i class="icon-twitter"></i><a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwhartonjournal.com%2F2017%2F04%2F22%2Fwelcome-the-new-editors%2F&amp;text=Welcome+the+New+Editors">Twitter</a><span class="digit digit-twitter">0</span></li>
					<li class="facebook"><i class="icon-facebook-sign"></i><a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwhartonjournal.com%2F2017%2F04%2F22%2Fwelcome-the-new-editors%2F&amp;t=Welcome+the+New+Editors" >Facebook</a><span class="digit digit-facebook">0</span></li>
					<li class="google"><i class="icon-google-plus-sign"></i><a href="https://plus.google.com/share?url=http%3A%2F%2Fwhartonjournal.com%2F2017%2F04%2F22%2Fwelcome-the-new-editors%2F" >Google +</a><span>0</span></li>
					<li class="linkedin"><i class="icon-linkedin-sign"></i><a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fwhartonjournal.com%2F2017%2F04%2F22%2Fwelcome-the-new-editors%2F&amp;title=Welcome+the+New+Editors&amp;summary=Name%3A%20Emmanuel%20Chimezie%20Title%3A%20Editor-In-Chief%20Best%20%26amp%3B%20worst%20moment%20at%20Wharton%20so%20far%3A%20Best%3A%20Seeing%20Clyde%20open%20for%20Yung%20Joc.%20Worst%3A%20Spending%20too%20much%20time%20on%20CS%20Vision%20for%20WJ%3A%20The%20Wharton%20Journal%20has%20a%20long%20history%20and%20I%20hope%20to%20contribute%20what%20I%20can%20to%20a%20great%20brand%20%26%238211%3B%20by%20increasing%20readership%20among%20current%3Ca%20href%3D%22http%3A%2F%2Fwhartonjournal.com%2F2017%2F04%2F22%2Fwelcome-the-new-editors%2F%22%20title%3D%22Read%20more%22%20%3E...%3C%2Fa%3E">Linkedin</a><span class="digit digit-linkedin">0</span></li>
					<li class="email"><i class="icon-envelope-alt"></i><a href="mailto:?Subject=Welcome+the+New+Editors&amp;body=http%3A%2F%2Fwhartonjournal.com%2F2017%2F04%2F22%2Fwelcome-the-new-editors%2F">Email this article</a></li>
										<li class="print"><i class="icon-print"></i><a href="#" onclick="window.print();">Print this article</a></li>
									</ul>
			</div>

							<div class="co-author">
				<span class="title-action">Authors</span>
				
					<div class="author-info">
						<img alt='' src='http://1.gravatar.com/avatar/196ff34e9266b8d6a970ba3cd8a9f29b?s=96&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/196ff34e9266b8d6a970ba3cd8a9f29b?s=192&amp;d=mm&amp;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' />						<a foo="baz" class="author-name" href="http://whartonjournal.com/author/whartonjournal/" rel="author">The Wharton Journal</a></h2>
					</div><!-- .author-info -->

								</div>
			
			 		</div>
		
</article><!-- #post-6366 -->
		

	
		
		
			

<div id="comments" class="comments-area">

		
	

	


							<div id="respond" class="comment-respond">
				<h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/04/22/welcome-the-new-editors/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=welcome-the-new-editors#respond" style="display:none;">Cancel reply</a></small></h3>
									<p class="must-log-in">You must be <a href="http://whartonjournal.com/wp-login.php?redirect_to=http%3A%2F%2Fwhartonjournal.com%2F2017%2F04%2F22%2Fwelcome-the-new-editors%2F">logged in</a> to post a comment.</p>												</div><!-- #respond -->
			        <script type="text/javascript">
            jQuery(document).ready(function () {
                jQuery('#commentform').submit(function () {
                    _gaq.push(
                            ['_setAccount', 'UA-26359921-1'],
                            ['_trackEvent', 'comment', 'submit']
                    );
                });
            });
        </script>
		
</div><!-- #comments .comments-area -->
		</div>

  	
	    <div id="secondary" class="widget-area span3" role="complementary">
		<aside id="mostreadpostswidget-9" class="widget widget_mostreadpostswidget"><h3 class="widget-title">Most Read Posts</h3><ul class="mlrp_ul">
        <li><a title="Why I Left Wharton" href="http://whartonjournal.com/2017/03/29/why-i-left-wharton-2/">Why I Left Wharton</a>
					<span class="most_and_least_read_posts_hits"> (16,213 views)</span>
          
				</li>
        <li><a title="Africa Global Immersion Program(GIP) Trip" href="http://whartonjournal.com/2017/03/30/africa-global-immersion-programgip-trip/">Africa Global Immersion Program(GIP) Trip</a>
					<span class="most_and_least_read_posts_hits"> (2,738 views)</span>
          
				</li>
        <li><a title="What’s new in the MBA curriculum?" href="http://whartonjournal.com/2017/03/29/whats-new-in-the-mba-curriculum/">What’s new in the MBA curriculum?</a>
					<span class="most_and_least_read_posts_hits"> (2,727 views)</span>
          
				</li>
        <li><a title="That’s a wrap!" href="http://whartonjournal.com/2017/04/12/thats-a-wrap/">That’s a wrap!</a>
					<span class="most_and_least_read_posts_hits"> (2,719 views)</span>
          
				</li>
        <li><a title="Welcome to the Class of 2019 from the WGA President" href="http://whartonjournal.com/2017/04/22/welcome-to-the-class-of-2019-from-the-wga-president/">Welcome to the Class of 2019 from the WGA President</a>
					<span class="most_and_least_read_posts_hits"> (2,622 views)</span>
          
				</li>
        <li><a title="Remembering Benji After Social Impact Week" href="http://whartonjournal.com/2017/04/12/remembering-benji-after-social-impact-week/">Remembering Benji After Social Impact Week</a>
					<span class="most_and_least_read_posts_hits"> (2,102 views)</span>
          
				</li>
        <li><a title="Are Wharton Students Wasteful?" href="http://whartonjournal.com/2017/03/29/are-wharton-students-wasteful/">Are Wharton Students Wasteful?</a>
					<span class="most_and_least_read_posts_hits"> (1,980 views)</span>
          
				</li>
        <li><a title="Embracing Students and Alumni" href="http://whartonjournal.com/2017/03/29/embracing-students-and-alumni/">Embracing Students and Alumni</a>
					<span class="most_and_least_read_posts_hits"> (1,693 views)</span>
          
				</li>
        <li><a title="Class Gift 2017 – Pay It Forward!" href="http://whartonjournal.com/2017/03/21/class-gift-2017-pay-it-forward/">Class Gift 2017 – Pay It Forward!</a>
					<span class="most_and_least_read_posts_hits"> (1,692 views)</span>
          
				</li>
        <li><a title="A journey towards launching my fashion label: Whole9yards" href="http://whartonjournal.com/2017/04/12/a-journey-towards-launching-my-fashion-label-whole9yards/">A journey towards launching my fashion label: Whole9yards</a>
					<span class="most_and_least_read_posts_hits"> (1,639 views)</span>
          
				</li></ul>
		<div style="clear:both;"></div></aside><aside id="text-4" class="widget widget_text"><h3 class="widget-title">Request Advertising Info</h3>			<div class="textwidget"><div class="wpcf7" id="wpcf7-f98-w1-o1"><form action="/2017/04/22/welcome-the-new-editors/?utm_source=rss&utm_medium=rss&utm_campaign=welcome-the-new-editors#wpcf7-f98-w1-o1" method="post" class="wpcf7-form">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="98" />
<input type="hidden" name="_wpcf7_version" value="3.3.1" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f98-w1-o1" />
<input type="hidden" name="_wpnonce" value="72b3023d1f" />
</div>
<p>Your Name (required)<br />
    <span class="wpcf7-form-control-wrap your-name"><input type="text" name="your-name" value="" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" size="40" /></span> </p>
<p>Your Email (required)<br />
    <span class="wpcf7-form-control-wrap your-email"><input type="text" name="your-email" value="" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" size="40" /></span> </p>
<p>Subject<br />
    <span class="wpcf7-form-control-wrap your-subject"><input type="text" name="your-subject" value="" class="wpcf7-form-control wpcf7-text" size="40" /></span> </p>
<p>Your Message<br />
    <span class="wpcf7-form-control-wrap your-message"><textarea name="your-message" class="wpcf7-form-control  wpcf7-textarea" cols="40" rows="10"></textarea></span> </p>
<p><input type="submit" value="Send" class="wpcf7-form-control  wpcf7-submit" /></p>
<div class="wpcf7-response-output wpcf7-display-none"></div></form></div></div>
		</aside><aside id="text-5" class="widget widget_text"><h3 class="widget-title">Contact the Editors</h3>			<div class="textwidget"><div class="wpcf7" id="wpcf7-f35-w2-o1"><form action="/2017/04/22/welcome-the-new-editors/?utm_source=rss&utm_medium=rss&utm_campaign=welcome-the-new-editors#wpcf7-f35-w2-o1" method="post" class="wpcf7-form">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="35" />
<input type="hidden" name="_wpcf7_version" value="3.3.1" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f35-w2-o1" />
<input type="hidden" name="_wpnonce" value="9963f04be5" />
</div>
<p>Your Name (required)<br />
    <span class="wpcf7-form-control-wrap your-name"><input type="text" name="your-name" value="" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" size="40" /></span> </p>
<p>Your Email (required)<br />
    <span class="wpcf7-form-control-wrap your-email"><input type="text" name="your-email" value="" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" size="40" /></span> </p>
<p>Subject<br />
    <span class="wpcf7-form-control-wrap your-subject"><input type="text" name="your-subject" value="" class="wpcf7-form-control wpcf7-text" size="40" /></span> </p>
<p>Your Message<br />
    <span class="wpcf7-form-control-wrap your-message"><textarea name="your-message" class="wpcf7-form-control  wpcf7-textarea" cols="40" rows="10"></textarea></span> </p>
<p><input type="submit" value="Send" class="wpcf7-form-control  wpcf7-submit" /></p>
<div class="wpcf7-response-output wpcf7-display-none"></div></form></div></div>
		</aside>	</div>
	            </div>
         </div>
     </div>

    
    <!-- Footer -->
    <footer id="colophon" class="site-footer dark" role="contentinfo">
        <div class="container">

            <div id="site-tools">
                <div class="row-fluid">
                    <div class="span9"><ul class="breadcrumbs"><li itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="http://whartonjournal.com"><span itemprop="title">Wharton Journal</span></a> </li> <li itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="http://whartonjournal.com/category/clubs/"><span itemprop="title">Clubs</span></a></li><li> Welcome the New Editors</li></ul></div>
                                    </div>
            </div>

            
            <div class="footer-shadown"></div>
        </div>

        <div id="site-info" class="container">
            <div class="clearfix">
                <div class="copyright">
                    <p>Copyright &copy; 2012 by <a href="http://demo.designwall.com/dw-focus/" title="DW Focus" rel="nofollow">DW Focus</a>. Proudly powered by <a href="http://wordpress.org/" title="Semantic Personal Publishing Platform">WordPress</a></p>
                    <p><a title="Responsive WordPress Themes for Free and Premium" href="http://designwall.com/" rel="nofollow">WordPress Theme by DesignWall</a></p>
                </div>
                <div class="logo">
                    <a class="small-logo" href="http://whartonjournal.com/" title="Wharton Journal" rel="home">Wharton Journal</a>
                </div>
            </div>
        </div>
    </footer><!-- #colophon .site-footer -->
<a class="scroll-top" href="#masthead" title="Scroll to top">Top</a>
<script type="text/javascript">
				jQuery("#tp_thumbs").delegate("img","hover", function(){
				jQuery("#largeImage").attr("src",jQuery(this).attr("src").replace("thumb","large"));
				jQuery("#description").html(jQuery(this).attr("alt"));
			});
		  </script><script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/whartonjournal.com\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","sending":"Sending ..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://whartonjournal.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=3.3.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="http:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
<div id="fb-root"></div></body>
</html>